Improved thumbnails and 'popular listings' column on the Bistro

talk-admin

Administrator
Staff member
#1
Hi all,
Two improvements for DiamondBistro.com today:
1 - Thumbnails are now cleverly made from original photos with no distortion during resizing and consistent final size (tricky since user photos are of varying width/height). The home page thus looks much cleaner now and listing photos are much easier to view.


2 - Popular listings now only considers listings from the last 3 months, on a rolling basis. This ensures that category is reflective of recent listings rather than the semi-permanent list before which was dominated by the same listings perpetually.

More improvements coming as well - please visit and let us know your feedback! DiamondBistro.com: Dedicated Jewelry Classifieds, Buy and Sell New and Used Jewelry

Best regards,
Less
 
#2
Less - this is the view I have of the Bistro home page now - I’m using Chrome and on an ipad. Cara
C9D7DDF8-B309-47B0-827D-99DFF0F31411.png Less...this is the view I have now have of the bistro home page. I’m using chrome and on an ipad. Photo attached.
 

talk-admin

Administrator
Staff member
#3
Less - this is the view I have of the Bistro home page now - I’m using Chrome and on an ipad. Cara
View attachment 27911 Less...this is the view I have now have of the bistro home page. I’m using chrome and on an ipad. Photo attached.
Hi Cara,
Ouch sorry about this - I'm pretty sure what is happening is Chrome is confused between the cached thumbnails already on your ipad vs the new ones so it's not loading the new ones, but the old ones are getting clipped via the new page css which expects the new size images vs the older large ones.

You can test it via using the 'incognito' Chrome option (click the top right three dots, select new 'incognito' tab) - this will make a new browser instance and not use your local cache and then if you visit diamondbistro.com it should load and display as expected.
If that works, then you can just hit three dots again on top right, then More tools and then "clear browsing data". That will then remove the old thumbnails and force it to use the new images.

Hope that helps and thanks again for the feedback!
Less
 

talk-admin

Administrator
Staff member
#7
Hi Cara,
Can you do the "More tools" and then "clear all browsing data" (you can just select files and leave cookies, etc).
That will fix it.
I had the same issue on my laptop so was good chance to verify the fix.
We're checking if there is a way for us to tell the browser to not used cached images but for now manually doing it is only fix...it will also auto-fix once the browser cache expires but that could take days.

Best regards,
Less
 

talk-admin

Administrator
Staff member
#8
I’m browsing on Safari on an iPad Pro. The listings look clipped, like Cara’s screen capture shows.
Hi Cricketgrrl!
Can you use the Safari menu to delete browsing data (may let you just do it for diamondbistro) but basically use the menu to force it to remove any previous cached images...that will force it to ask for all new images when you visit db and then it will look as expected.
Sorry for the hassle - we're working on how to tell the browser to go get new images programatically for the future!

Hope you are doing well,
Less
 

talk-admin

Administrator
Staff member
#9
Hi Cara,
Can you do the "More tools" and then "clear all browsing data" (you can just select files and leave cookies, etc).
That will fix it.
I had the same issue on my laptop so was good chance to verify the fix.
We're checking if there is a way for us to tell the browser to not used cached images but for now manually doing it is only fix...it will also auto-fix once the browser cache expires but that could take days.

Best regards,
Less
I hit the same issue on my tablet last night. Clearing the cache fixes it.
One change though on tablet, the menu is a bit different - you have to click on top right corner to get menu (three dots) and then History and then "Clear Browsing Data".

Best regards,
Less
 
#12
Hi Cara,
Can you do the "More tools" and then "clear all browsing data" (you can just select files and leave cookies, etc).
That will fix it.
I had the same issue on my laptop so was good chance to verify the fix.
We're checking if there is a way for us to tell the browser to not used cached images but for now manually doing it is only fix...it will also auto-fix once the browser cache expires but that could take days.

Best regards,
Less
Less...on my ipad there is no “more tools” or “clear browsing data”. Not that I can see (I use Chrome on my Ipad)
 
Last edited:

Dana ♥

The Centenary Diamond
#13
FWIW i had the same issue on my computer, and a hard refresh fixed it.

that won't help y'all who are using iPads or Safari, but in case anyone else has seen that issue, that's one way to fix it.
 
#14
FWIW i had the same issue on my computer, and a hard refresh fixed it.

that won't help y'all who are using iPads or Safari, but in case anyone else has seen that issue, that's one way to fix it.
On my Ipad in Chrome I can’t seem to fix it - however, I don’t use Safari ...and decided to open it to see if ok in Safari on my IPAD - The site looks fine in Safari on my IPAD but, not Chrome which is what I use on my Ipad.
 

talk-admin

Administrator
Staff member
#15
Less...on my ipad there is no “more tools” or “clear browsing data”. Not that I can see (I use Chrome on my Ipad)
Hi FloweringEarth,
Thanks for the update! Glad one is working at least :)

Can you try visiting with your Chrome browser again? We made a fix that should force all browsers to auto-update the photos and thus avoid needing to clear the cache....this will (or should) ensure it's working for Ipad and Iphone devices that restrict access to the cache.

Hope you are doing well!
Less
 
#16
Hi FloweringEarth,
Thanks for the update! Glad one is working at least :)

Can you try visiting with your Chrome browser again? We made a fix that should force all browsers to auto-update the photos and thus avoid needing to clear the cache....this will (or should) ensure it's working for Ipad and Iphone devices that restrict access to the cache.

Hope you are doing well!
Less
Hey there...no luck at least not so far sadly
 

talk-admin

Administrator
Staff member
#17
Hey there...no luck at least not so far sadly
oh nuts - weird as we tested on an iphone for that fix.
Are the new listings showing up properly at least (top left column)? There's been 5+ new listings so those photos should show up with proper photos since they wont' exist in your cache.

We'll get it all fixed up for you but please let me know if the new listings are showing properly at least!
Best regards,
Less
 
#18
CB5BE89C-38D5-4478-9031-C80B7BAC768D.png
oh nuts - weird as we tested on an iphone for that fix.
Are the new listings showing up properly at least (top left column)? There's been 5+ new listings so those photos should show up with proper photos since they wont' exist in your cache.

We'll get it all fixed up for you but please let me know if the new listings are showing properly at least!
Best regards,
Less
This is what I see Less
 

talk-admin

Administrator
Staff member
#20
I get a giggle that the ads are full size though:)
Hi FloweringEarth,
Can you hit the refresh button on your browser once you are on the page? That should force your browser to pull the updated page and fix once and for all.

Re: ads - that's b/c we didn't change anything for the ad display section. The changes were all to the listing images and improving how the the thumbnails for the home page are created and displayed to make sure they are all the same size without distortion.

The manual refresh (via hitting the browser refresh button) should pull all the new files and fix but pls let me know!
Best regards,
Less
 
Top